Crystal Report Viewer:
Failed to retrieve data from the database.
Details: [Database Vendor Code: 229]
Root Cause:
The Database Vendor is Microsoft SQL server, and the error code is a Microsoft SQL error code.
Microsoft support information about error code 229 is:
This error occurs when a Microsoft® SQL Server™ user attempts an action, such as executing a stored procedure, or reading or modifying a table, for which the user does not have the appropriate privileges.
This SQL error would indicate the SQL login specific to the built-in report has not been granted the proper access rights and permissions to the Service database.
Built-in reports are Servicing Director screens which open from an application button, and the screens are created by displaying a Crystal Report page. Examples of built-in reports are the Customer Service, Collections, Disbursements, and Tracking applications all have a History button built-in report, and the Customer Service or Collections application have a Payoff Send button. For another example, the Investor Accounting application Reports button has the Investor Accounting Cutoff reports.
Workaround:
The logins for the Servicing Director applications are installed automatically by the Servicing Director Database installation program, and the logins will have the proper access rights and permissions maintained with each upgrade.
Normal use of the Servicing Director applications does not change the login access or permissions.
Therefore, contact your local IT to review changes made outside of the product to the login access rights or permissions.
The built-in reports use a unique login named Reports, a login different from the login used to log into Servicing Director.
You can use the Servicing Director LSCNFG program on the SQL server with the Run Fixrights option to reset the logins back to the automatically created proper access rights and permissions. See other articles about how to run the LSCNFG program.
ArticleNumber:
000042026