Customer Self-Service Browser Error Could Not Load File or Assembly ILSBusiness

Customer Self-Service Browser Error Could Not Load File or Assembly ILSBusiness

Server Error in '/ILSWeb' Application.

Could not load file or assembly ‘ILSBusiness’ or one of its dependencies. An attempt was made to load a program with an incorrect format.

Exception Details: System.BadImageFormatException: Could not load file or assembly 'ILSBusiness' or one of its dependencies. An attempt was made to load a program with an incorrect format. 


Root Cause:

The IIS Application pool for the Customer Self-Service ILSWeb application does not have 32-bit applications enabled. 


Workaround:

Have your local IT or system administrator do the following on the Customer Self-Service web server:

  1. Open IIS Manager. 

  2. Expand the Application Pools. 

  3. Click on the ILSWeb1 application pool. 

  4. Click Advanced Settings. 

  5. Change the Enable 32-Bit Applications setting to True. 

  6. Click OK. 

ArticleNumber:

000042931