Customer Service Dates Screen Error: Enter a Date in the First Due Field That's Before the Current Due Date of the Loan

Customer Service Dates Screen Error: Enter a Date in the First Due Field That's Before the Current Due Date of the Loan

Enter a date in the first due field that's before the current due date of the loan


Root Cause:

When your are attempting to change the First Due Date on a loan in the Customer Service Dates screen, you may encounter this error. 

You cannot have a first due date which is before the loan due date. Typically on a new loan, these two dates should match.


Workaround:

You can change the loan due date in the Loan Adjustment screen (Customer Service > Other > Loan Adjustment).
After you have changed the loan due date, you should be able to modify the first due date on the Customer Service Dates screen.

 

Note

It is possible that after making these changes, you may get a warning message that the loan will now not mature on the maturity date that you specified.  This would mean you have to change the Maturity Date in the Dates screen. There is no perfect way to best handle this situation once the loan has been boarded incorrectly and amortized.

ArticleNumber:

000038595