Error Code 80040e09, IDispatch Error 3081-Microsoft OLE DB Provider, Select Permission Denied on Object.

Error Code 80040e09, IDispatch Error 3081-Microsoft OLE DB Provider, Select Permission Denied on Object.

You have received a system/network error. Please contact your supervisor and/or system administrator and reference the System and Network Error section in your Superview User Guide or Online Help.

The error information is as follows:

Error from EZTeller in GetDatabaseVersion

Code = 80040e09

Code meaning = IDispatch error #3081

Source = Microsoft OLE DB Provider for SQL Server

Description = Select permission denied on object DBCurrentState, database EZTeller, owner dbo


Root Cause:

This error occurs the first time a user logs into EZTeller. The user account created in the SQL server was not set up correctly.


Workaround:

Log into the SQL server:

  1. Click on the (+) in front of the Security folder.
  2. Open the Logins folder.
  3. Right-click on the employee's name that is getting the error.
  4. Select Properties.
  5. Verify that Enforce Password policy is not checked.
  6. Verify that the Default language is set to English.
  7. Select User Mapping under the Select a page section.
  8. In the Users mapped to this login section, verify that EZTeller is checked.
  9. In the Database role membership for: EZTeller section, verify that db_datareader and db_datawriter is checked.
  10. Click OK.
  11. Open EZTeller and have the user log in.

ArticleNumber:

000041325