Error Establishing Connection to the Printer When Starting EZTeller

Error Establishing Connection to the Printer When Starting EZTeller

An error occurred while establishing a connection to the printer. 


Root Cause:

This error message is encountered when starting EZTeller. There are several reasons why EZTeller software is not connecting to the printer.


Workaround:

Hardware:

  1. Verify that the printer and power cables are connected.
  2. The printer must have an ink cartridge, paper roll and must be powered up.
  3. Printer cables must be modem cables.
  • You may need to purchase a new cable such as the Belkin Components, Part # F2L044-10, DB9 Female / DB25 male


Another program could be using the com port:

  1. If Superview was opened first, it connected to the printer.
  2. A virtual PDF printer could be assigned to the same com port.

 

Settings do not match the actual com port connection:

To determine the com port:

  1. On the PC, exit EZTeller and Superview.
  2. Go to a DOS Command Prompt.
  • On a WinXP PC, go to Start > Run and type cmd and Enter.
  • On a Win7 PC, type cmd in the search box and Enter.
  1. At the DOS prompt, type: dir>com1 and Enter.
  2. If data prints then we know the printer is connected to Com Port 1.
  • If the data does not print, type: dir>com2 and Enter.
  • If the data does not print, type: dir>com3 and Enter and so on.
  1. Once you determine which com port the printer is connected to, then change the settings in Superview to match.


Changing the settings:

  1. Log into Superview at the same PC and select the branch as your workgroup.
  2. Go to Profile Options > Workstations > General and select the Workstation Name from the list.
  3. Go to the Validation Printing tab and verify that Device Type has the correct printer and that the Port is correct.
  4. Click Apply and OK.
  5. At this point, you should see a check mark on System > Printer.
  6. To test the printer connection, go to Branch > Totals and Print. 
  7. Uncheck Printer under System > Printer.
  8. Start EZTeller and verify that it connects to the printer.

 

Note: If the printer is not printing correctly, please see additional articles on configuring printers in EZTeller.

ArticleNumber:

000039666