Error In Addtransaction to Server Code=80040E07

Error In Addtransaction to Server Code=80040E07

You receive the following error message in EZTellerĀ® when entering a Hold Notice and are bumped into Database Disconnected.

FROM EZTELLER]:  - SQLERROR AT MM/DD/YYYY HH:MM:SS PM
 ERROR [FROM EZTELLER]:  IN ADDTRANSACTION(PTRANS) TO SERVER
 CODE = 80040E07
 CODE MEANING = IDISPATCH ERROR #3079
 SOURCE = MICROSOFT OLE DB PROVIDER FOR SQL SERVER
 DESCRIPTION = ERROR CONVERTING DATA TYPE VARCHAR TO DATETIME.


Root Cause:

This error occurs when an invalid date is entered in the Hold Notice, Date of Deposit field in EZTeller. EZTeller becomes database disconnected.


Workaround:

Applicationteller has done any transactions after receiving the error message:

 

  1. Print the EZTeller journal, transactions will be lost while EZTeller is database disconnected.
  2. Write down the ending cash total displayed at the bottom of EZTeller.
  3. Exit EZTeller.
  4. Rename or delete the EZLocalCacheENT.mdb file.

Note: This file is located:

  • WinXP-C:\Documents and Setting\All Users\Application Data\EZTeller folder.
  • Win7-C:\Users\Program Data.
  1. Restart EZTeller.
  2. Click on Other > Hold Notice and enter the correct date in the Date of Deposit field.

 

ArticleNumber:

000039662