Servicing Director Applications Error: "Communication link failure"
Communication link failure
Root Cause:
There are several different error messages possible, but all of them contain these key words above.
These key words in the error message indicate the network connections from the Servicing Director applications to the Servicing Director database server, which were once established and working, were unexpectedly ended.
Workaround:
The Servicing Director applications rely on Microsoft Windows provided Open Database Connectivity (ODBC) connections to the database server, and therefore, the cause for the error is outside of the Servicing Director application.
To address this issue see options listed below:
- Have your local IT troubleshoot this issue as a local networking or Windows issue, where the established connections to the database server were all ended by something other than the Servicing Director applications.
- Tell your local IT whether you have had the Servicing Director applications open and left inactive and for how long. Sometimes your IT may have network devices configured to close idle network connections, which could lead to this outcome.
- Also note whether your computer went into sleep-mode, where it uses less power, and possibly ended your network connections. It is important to also know if your Windows computer is rebooted every night or periodically, or instead left on across many days.
- The Servicing Director applications open many connections to the database server, as many as one connection per screen, and as long as any Servicing Director screen is open, the connection is expected to remain established. If the desktop user is not actively using the screen, then the established connection will be idle without any network activity until the user is active with the screen again. Therefore, the connection could be unexpectedly ended without the desktop user noticing, until the user is active with the screen, at which point some form of the error above will appear for every screen open at the time.
The open screens cannot continue without the original database connection, and any screen information not already saved will be lost and the screen will have to be closed.
As a workaround, close all the Servicing Director screens and clear any error messages, and try to log into Servicing Director again. If your network issue or Windows issue is no longer present, then you will be able to log into Servicing Director again.
ArticleNumber:
000039135