Servicing Director Customer Self-Service Installation Error: "...Error 1722...aspnet_regiis.exe..."

Servicing Director Customer Self-Service Installation Error: "...Error 1722...aspnet_regiis.exe..."

Product: Servicing Director Customer Self-Service Web <Business or Investor>-- Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. Action UpdateWebAppMapping, location: C:\inetpub\wwwroot\ILSWebBus\, command: C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe -s "W3SVC/1/ROOT/ILSWebBus" 

This error causes the installation to fail with this final message:

Setup Wizard ended prematurely because of an error.

 


Root Cause:

This message is found in the Servicing Director log file, the installation log file for the Customer Self-Service product you are installing.  This error can occur on the Web, Investor, or Business Application server. 

This error message is from Windows, where the Windows ASP.NET is not ready to be configured for Customer Self-Service by the installation. There can be a number of Windows conditions which can cause this error, and the exact Windows condition is not indicated by the error. 

 

 


Workaround:

Generally speaking, the error message shows the installation attempting an ASP.NET configuration command using the Microsoft provided aspnet_regiis.exe.
This Windows command registers the Customer Self-Service web application with Windows ASP.NET and Windows had some failure executing that command which is not shown.

Use your Microsoft support resources to resolve this ASP.NET issue.

You may be able to reveal the Windows failure with this ASP.NET command by running same command yourself interactively from an administrator's  Command Prompt.  Running the command interactively should receive an error message from Windows which will lead your troubleshooting to Microsoft support resolutions for the message you receive. 

Here is the command line isolated from the rest of the installation log error: 

C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe -s "W3SVC/1/ROOT/ILSWebBus" 

Note:  In this sample command, the Customer Self-Service product is for the Business Application server (ILSWebBus), but as shown in your log file, the command may be for the Web (ILSWeb) or Investor (ILSWebInvestor) instead. 

Once you can run this command successfully, then retry the Customer Self-Service installation, and this issue should be resolved.

ArticleNumber:

000043309