Servicing Director Customer Self-Service Installation Fails with Error: "...Setup Wizard ended prematurely because of an error..."
Servicing Director Customer Self-Service <name of installation program> Setup Wizard ended prematurely because of an error. Your system has not been modified. To install this program at a later time, run Setup Wizard again. Click the Finish button to exit the Setup Wizard.
Root Cause:
There can be more than one cause for this error, but the most common causes for this error are:
- Windows requires the administrator user to still use elevated "Run As Administrator" procedures to have permission to perform the installation.
- Windows needs to be rebooted.
Workaround:
- Save a copy of the Customer Self-Service installation log file. For more information about the log file, search Knowledge Center with the keywords "Servicing Director log file".
- Reboot the Windows computer.
- Use the Microsoft procedures which give you elevated administrator access, such as using "Run as Administrator" procedure in combination with a Windows Command Prompt to start the Installation. Refer to your Microsoft support resources for information about using the "Run As Administrator" procedures with Microsoft Installer.
- Try the Customer Self-Service installation program again.
ArticleNumber:
000042622