Servicing Director Customer Self-Service Monthly Billing Statement Error: There Was a Problem Creating the Statement...
There was a problem creating the statement for download. Please contact customer service for assistance.
Root Cause:
This error is usually caused by an incorrect configuration of Customer Self-Service.
Workaround:
To create a statement, your Customer Self-Service must have the following configured correctly:
- The SAP Crystal Reports Runtime is installed on the Business Application web server (ILSWebBus).
- The Crystal Reports Runtime.MSI from your Customer Self-Service installation files installs this.
- Be sure to install this using the Windows right-click > Run As Administrator command if available.
- See your Customer Self-Service Installation Guide for more information about installing this.
- The IIS User is assigned Full Control File Permissions to the \ILSWebBus\Rpt and \Windows\Temp folders on the Business Application web server (ILSWebBus).
- This granting of permission is commonly a challenging step during the installation procedures, since it can be difficult to determine which Windows account is running your IIS application when each system may be different.
- Note which folders you have changed as part of this step, and which Windows accounts were granted access.
- See your Customer Self-Service Installation Guide for more information about assigning these permissions.
After confirming the configuration steps above, if the error continues, then also do the following:
- Check the Business Application web server \ILSWebBus\Rpt folder for a file named ReportDebug.txt.
- This file is a troubleshooting file made during some stages of creating a statement.
- If the ReportDebug.txt has a current Windows file modified date and time, the file may have additional details about this error.
- If you have a ReportDebug.txt with current details, contact customer support using Case Management on the Finastra Customer Success Community website, and upload the ReportDebug.txt file to the support case.
- Confirm you have a data source in the Windows Data Sources (ODBC) Control Panel named "Servicing" on the Business Application web server (ILSWebBus) configured to connect to your Servicing Director SQL server.
- This is a Windows 32 bit data source, so you will need to use the 32 bit Windows Data Sources (ODBC) Control Panel to view this configuration.
- If you do not have a data source named "Servicing", then you may not have had sufficient Windows administrator permission performing the Customer Self-Service Installation guide procedures, and will want to perform the Installation Guide procedures again using the Microsoft procedures necessary to have elevated administrator permissions.
- If you do have a data source named "Servicing", then be sure the server name configured in the data source is the correct server name for your Servicing Director SQL server.
ArticleNumber:
000039321