Servicing Director Customer Service Application Error: "Customer Service Application has stopped working...System.ReferenceException..."

Servicing Director Customer Service Application Error: "Customer Service Application has stopped working...System.ReferenceException..."

Customer Service Application has stopped working.
Problem details:
Event Name: CLR20r3
Response: Not available
Cab Id: 0

Problem signature:
P1: custsvc.exe
P2: 16.3.0.18
P3: 58355247
P4: cwrap
P5: 16.3.0.18
P6: 58354f38
P7: cf
P8: 40
P9: System.ReferenceException
P10: 

Windows Event Viewer Details:
Application: custsvc.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.ReferenceException
Stack:
   at CRptDoc.OpenReport(System.String, System.String)
   at <Module>.CWrap.OpenReport(CWrap*, ATL.CStringT<char,StrTraitMFC_DLL<char,ATL::ChTraitsCRT<char> > >*, ATL.CStringT<char,StrTraitMFC_DLL<char,ATL::ChTraitsCRT<char> > >*)


Root Cause:

This message indicates the application is trying to open a Crystal Reports template file, the .RPT file, and the report you are trying to open could not be found or read from the \SvcData\Rpt folder. 
The Customer Service application is commonly the application to open reports, which can fail in this way if the .RPT file could not be found or read, but other Servicing Director applications which open reports would also fail in this way if the .RPT could not be found or read. 


Workaround:

  • Confirm your \SvcData\Rpt folder has the .RPT file for the report, and the .RPT can be read. 
  • To locate your \SvcData folder, find the related article on the Finastra Customer Success Community Knowledge Center website by searching with the key words Servicing Director SvcData. 
  • To determine the Crystal Reports template file name, find the related article on the Finastra Customer Success Community Knowledge Center website by searching for the key words Servicing Director Template. 
  • If the error message occurs when clicking the Servicing Director History button, or Payoff Send button, then the Crystal Reports report is a built-in report. To determine the Crystal Reports template file name for a built-in report, find the related article on the Finastra Customer Success Community Knowledge Center website by searching for the key words Servicing Director Built-in. 
  • If the Crystal Reports template file is found in the \SvcData\Rpt folder, then possibly the file cannot be read. The Windows user account running the Servicing Director application is granted permission to read files based on your Windows permissions. Resolve issues reading the file by using Microsoft Windows methods to elevate, or otherwise change your Windows permissions, granting your Windows user permission to read, write, modify, and delete from the \SvcData folder and the folders within the \SvcData folder.
  • Your local IT should use Microsoft support as the support resource for how to change your Windows permissions.

ArticleNumber:

000042067