The install is unable to upgrade your version of the Service database.
The install is unable to upgrade your version of the Event Manager database.
Root Cause:
Your existing version of the Servicing Director database is too old to be upgraded by the version of the database installation.
Workaround:
In most cases, your existing version of Servicing Director must be one version older than the version of the upgrading database installation.
In other words, the database installation can usually only upgrade the prior version, and this error appears if you try to upgrade a version older than the prior version.
To resolve this error, upgrade your existing version of Servicing Director with the version which was released next after your version. For example, if you are on version 14.2 (with all the 14.2 service packs already applied), then upgrade using the 15.1 database installation first, the first full version released after 14.2.
Then continue to upgrade your version one version at a time until you are on the current version.
The best practice is to upgrade to each version of Servicing Director, in the order of their release, including any service packs released.
Have your business users review the release notes of each release before upgrading, making sure they prepare or act on any changes required. Some business users may need to make changes before upgrading, and the release notes will indicate that.
You can upgrade to each version back to back on the Servicing Director database server if desired.
You can save time by not upgrading the Servicing Director applications across multiple versions if you are not planning to actually operate on an intermediate version. Instead, you can upgrade your database server across several version and then after arriving at the final version on the server, upgrade your desktop applications once, directly to the final version matching your server, skipping intermediate versions on the desktop altogether.
ArticleNumber:
000040667