Faulting application name: custsvc.exe, version: 16.1.0.145, time stamp: 0x5719d28d
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x0b9310eb
Faulting process id: 0x1658
Faulting application start time: 0x01d1fd5be1ff40c7
Faulting application path: C:\Program Files (x86)\D+H\Servicing Director\custsvc.exe
Faulting module path: unknown
Report Id: 4b0f2ab4-6950-11e6-b4d4-28b2bdbe3f56
And:
Application: custsvc.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.AccessViolationException
at System.Windows.Forms.UnsafeNativeMethods.GetProcAddress(System.Runtime.InteropServices.HandleRef, System.String)
at System.Windows.Forms.Application.get_ComCtlSupportsVisualStyles()
at System.Windows.Forms.ToolStripGrip..ctor()
at System.Windows.Forms.ToolStrip.get_Grip()
at System.Windows.Forms.ToolStrip.get_DisplayRectangle()
at System.Windows.Forms.ToolStripSplitStackLayout.LayoutCore(System.Windows.Forms.Layout.IArrangedElement, System.Windows.Forms.LayoutEventArgs)
at System.Windows.Forms.Layout.LayoutEngine.Layout(System.Object, System.Windows.Forms.LayoutEventArgs)
at System.Windows.Forms.Control.OnLayout(System.Windows.Forms.LayoutEventArgs)
at System.Windows.Forms.ScrollableControl.OnLayout(System.Windows.Forms.LayoutEventArgs)
at System.Windows.Forms.ToolStrip.OnLayout(System.Windows.Forms.LayoutEventArgs)
at System.Windows.Forms.Control.PerformLayout(System.Windows.Forms.LayoutEventArgs)
at System.Windows.Forms.Control.PerformLayout()
at System.Windows.Forms.Control.ResumeLayout(Boolean)
at System.Windows.Forms.ToolStrip..ctor()
at CrystalDecisions.Windows.Forms.CrystalReportViewer.InitReportViewer()
at CrystalDecisions.Windows.Forms.CrystalReportViewer..ctor()
at CReportViewer13.InitializeComponent()
at CReportViewer13..ctor(System.String, Boolean, CRptDoc)
at <Module>.CWrap.CreateViewer(CWrap*, ATL.CStringT<char,StrTraitMFC_DLL<char,ATL::ChTraitsCRT<char> > >*, ATL.CStringT<char,StrTraitMFC_DLL<char,ATL::ChTraitsCRT<char> > >*, Boolean)
Root Cause:
The Crystal Reports report viewer application
Workaround:
When clicking the History button or other application button which is a built-in Crystal Reports created screen, the applications do not open the screen, and instead Windows reports the application must be closed or terminated by Windows. Some would describe this as the application "crashes".
This symptom can be intermittent, and the clicking the button may open the screen successfully on some attempts (particularly after opening Servicing Director).
To reinstall the Crystal Reports report viewer, do the following:
- Uninstall from the Windows installed programs control panel the program named "The SAP Crystal Reports runtime engine for .NET Framework (32-bit)".
- Delete the directory/folder that the SAP Crystal Reports runtime engine was using, which by default is:
C:\Program Files (x86)\SAP BusinessObjects\Crystal Reports for .NET Framework 4.0
- Reboot Windows.
- Install the Crystal Reports report viewer again. Install the Crystal Reports reports viewer which specifically has version #13.0.15.1840 version found here:
http://downloads.businessobjects.com/akdlm/cr4vs2010/CRforVS_redist_install_32bit_13_0_15_clone.zip
- This should resolve the issue.
ArticleNumber:
000042735
Related Articles
History or Other Built-In Report Screen Causes the Application to be Closed by Windows
Clicking the Fusion Servicing Director History button or other application button, which is a built-in Crystal Reports-created screen, the applications do not open the screen. Instead, Windows reports that the application must be closed or terminated ...
Online payment event viewer warning: an unhandled exception has occurred
In Fusion Servicing Director Customer Self-Service, when you click continue on the Online Payment Terms Screen (ACHWebIntro.ASPX), it can cause the following Windows Event Viewer Application log ASP.NET warning message when the settings on the ...
Servicing Director 15.x History or Other Built-In Report Screen Causes the Application to Stop Responding
After upgrading to Servicing Director 15.x, clicking the History button or other application button which is a built-in Crystal Reports created screen, the applications do not open the screen, and instead stop responding or "freeze". There is no ...
Servicing Director 15.x History and Other Screen Windows Event Viewer Error: "...Log on failed..."
Exception Information Log on failed. Stack Trace Information at CrystalDecisions.CrystalReports.Engine.ReportDocument.VerifyDatabase() at CRptDoc.SetLogonInfo(String DSN, String DB, String UID, String PWD) Root Cause: Servicing Director 15.1, 15.2, ...
LSCNFG Server Application Error: The Process was Terminated
Application: LSCnfg.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.IO.FileNotFoundException at <Module>.CLSCnfgDlg.{CTOR}(CLSCnfgDlg*, CWnd*) at ...