Servicing Director Link (SD Link) Connectivity Test Error: "...Valid connection from Web Service to SQL Server: False..."

Servicing Director Link (SD Link) Connectivity Test Error: "...Valid connection from Web Service to SQL Server: False..."

<SQLServer></SQLServer><Database></Database><UserName></UserName><ConnectionTest>Valid connection from Web Service to SQL Server: False</ConnectionTest><ConnectionTest>Valid connection from COM component to SQL Server: True</ConnectionTest><TestXMLMessage><ConnectServiceRequest>
<Service Name="ILSGetLoanDetails"><Instructions><HFSRq><AcctHistARMRq><LoanId>0000000000</LoanId><HistCounter>1</HistCounter></AcctHistARMRq>
</HFSRq></Instructions></Service></ConnectServiceRequest></TestXMLMessage><COMResponse></COMResponse></string>


Root Cause:

Typically, this error message means the Servicing Director Link (SD Link) web service providing the UltraData interface to Servicing Director is missing the prerequisite setup of the connection to the Servicing Director database server.


Workaround:

Working with your local IT, complete the SD Link prerequisite step on your on-site web (IIS) server.

Connecting to the Database Server
The database connectivity setup will attempt to create a registry and ODBC entry, so only users with administrative privileges can set it up.

  1. On the web service server, click Start > Programs > D+H > Servicing Director > Servicing Director Link Connection Editor.
  2. In the Server field, enter your Servicing Director Database SQL Server or SQL Server instance name.
  3. Verify that the Database field is set to Service (the database name is Service by default.)
  4. Verify that the Username field is set to ILSWebUser.
    Note: Do not change the Username field.
  5. In the Password field:
    1. Enter the default ILSWebUser password (which is #WebUserILS123!#)
      Or
    2. Enter your custom password if you have changed the ILSWebUser login password after installing the current version of Servicing Director on the SQL Server.
  6. Click Save. You will see a message to restart IIS.
  7. Click OK, and then restart IIS.

ArticleNumber:

000044177