Unable to Delete Record, User has Modifying History

Unable to Delete Record, User has Modifying History

When attempting to Delete a User from Fusion Serving Director the following error message appears: Unable to delete record, user has modifying history.

Root Cause:

There are a few conditions which limit the ability to delete users and typically keeping intact a history configured for the system is reason for the limitation.
 

Workaround:

If you track organization hierarchy, you cannot delete a user with associated hierarchy history records; so, instead, you must set that user to Inactive.
Note: If the user is assigned tasks in Task Tracking, you must reassign the tasks before you set the user to Inactive.

  1. Go to System Administration > Security Setup.
  2. Select the user.
  3. Click on Edit.
  4. Select Inactive box on the Edit User screen.
  5. Click OK to Save.

ArticleNumber:

000042387