A Rounding Error has Occurred

A Rounding Error has Occurred

A Rounding Error has Occurred


Root Cause:

When processing a payment from unapplied in the Servicing Director Payment Processing Module, you may encounter this error.

This error is related to how the data has been stored in the database.

This is an issue for your local IT or Database Administrator.

Rounding problems usually occur when using a custom loan import, where the data for the loan is imported into the database using methods other then those methods installed by the Servicing Director product.

In the background processing on the database, the payment being made does not exactly match the payment amount stored in the database. For instance, in the database, the value 100.50 does not exactly match the value 100.5000, which leads the database to perform some rounding on the value. 

This database detail would not be obvious or visible to someone using just the Servicing Director applications.


Workaround:

Support information is limited for issues outside of the Servicing Director applications as installed. Below is general information for your local IT or Database Administrator to check the payment values in the database:

  1. Check the following fields in the Loan table:
  • PrincipalBal
  • UnappliedBal
  • EscrowBal
  1. Check the following field in the Participation table, PrincipalBalInvShare.

 

Note: Your IT or Database Administrator may find how to resolve this issue by updating these fields for the loan to round to 2 decimals. Please ensure the resolution is tested on your Test/QA environment, and only after securing a backup that can be restored.

 

The authority for your custom import will be the engineering source of the import process.  If you purchased the import process from the Servicing Director Customization Professional Services department, then add a case using Case Management for the issue and request it be sent to the Customization department for support.
 

If the custom import was designed by your own resources, you can also request a quote from the Customization department to help you fix the problem. To make a request, add a case using Case Management for the issue and request it be sent to the Customization department for support.

ArticleNumber:

000038655

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