Customer Self-Service Online Payment Event Viewer Warning Index Was Out of Range

Customer Self-Service Online Payment Event Viewer Warning Index Was Out of Range

Log Name:      Application
Source:        ASP.NET 
Date:          
Event ID:      1309
Task Category: Web Event
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:     
Description:
Event code: 3005 
Event message: An unhandled exception has occurred. 
Event time: 
Event time (UTC):  
Event ID: 
Event sequence: 
Event occurrence:  
Event detail code: 
 
Application information: 
    Application domain:
    Trust level: Full 
    Application Virtual Path: /ILSWeb 
    Application Path: 
    Machine name: 
 
Process information: 
    Process ID: 
    Process name: w3wp.exe 
    Account name: 
 
Exception information: 
    Exception type: ArgumentOutOfRangeException 
    Exception message: Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index
   at System.ThrowHelper.ThrowArgumentOutOfRangeException(ExceptionArgument argument, ExceptionResource resource)
   at ILSWebData.AchWebDataEntry.getPaymentInfo(Byte AdvancedPmtRule)
   at ILSWebData.AchWebDataEntry.Page_Load(Object sender, EventArgs e)
   at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)
   at System.Web.UI.Control.OnLoad(EventArgs e)
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

 
Request information: 
    Request URL: /AchWebDataEntry.aspx 
    Request path: /AchWebDataEntry.aspx 
    User host address:  
    User: 
    Is authenticated: True 
    Authentication Type: 
    Thread account name: 
 
Thread information: 
    Thread ID: 44 
    Thread account name: 
    Is impersonating: False 
    Stack trace:    at System.ThrowHelper.ThrowArgumentOutOfRangeException(ExceptionArgument argument, ExceptionResource resource)
   at ILSWebData.AchWebDataEntry.getPaymentInfo(Byte AdvancedPmtRule)
   at ILSWebData.AchWebDataEntry.Page_Load(Object sender, EventArgs e)
   at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)
   at System.Web.UI.Control.OnLoad(EventArgs e)
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Root Cause:

Clicking Continue on the Online Payment Terms Screen (ACHWebIntro.ASPX) can cause this Windows Event Viewer Application log ASP.NET warning message when the web setup settings for Fusion Servicing Director are incorrect.

Workaround:

This information is for your system administrator or local IT:

  1. Reset your Servicing Director SQL logins, using the LSCNFG server application, adding on executing the W_FixRights SQL command..  For more information about resetting your Servicing Director SQL logins, search Knowledge Center with the keywords Resetting the Servicing Director SQL Server Logins.
  2. Restart your web services (IIS) on your Customer Self-Service business application server (ILSWebBus). If the issue is not resolved at this point, then continue with the advanced troubleshooting below.
    • If the computer name of your SQL server was changed in the past, after SQL Server was installed, then you may have a Microsoft SQL server issue. Review the Related article or search the Knowledge Center using the keywords "Servicing Director", "W_GetCompanyWorkdays", and "sys.servers". 
Advanced troubleshooting:
  1. Go to the Servicing Director SQL server
  2. Run the following troubleshooting SQL command. If an error occurs, it will be a SQL message about the root cause of this issue, and it will direct your further actions.
  3. Open the SQL Server Management Studio.
  4. Login specifically using SQL authentication and use only the SQL login ILSWebUser. This is the SQL login configured by the person installing the Customer Self-Service business application server. Use the default password defined in the Customer Self-Service Installation Guide or your custom password if the person installing Customer Self-Service defined a custom password.
  5. Click New Query.
  6. Enter the following query:
Use Service
Go
Service.dbo.W_GetCompanyWorkdays
Go
 
If the settings for this query on your system are correct, then the results from the query should return the business days from the Event Manager calendar.  If the settings for this query on your system are incorrect, you will see a SQL error message, and use the error message to direct your further troubleshooting, Reference your Microsoft SQL Support resources as needed.

ArticleNumber:

000043214