Crystal Report Viewer
Failed to open the connection.
Details: [Database Vendor Code: 4060]
Root Cause:
The Database Vendor is Microsoft SQL server, and the error code is a Microsoft SQL error code.
Microsoft support information about error code 4060 is this:
"Server rejected the connection; Access to selected database has been denied"
This SQL error would indicate the SQL login specific to the Customer History button has not been granted the proper access rights and permissions to the Service database.
Workaround:
The logins for the Servicing Director applications are installed automatically by the Servicing Director Database installation program, and the logins will have the proper access rights and permissions maintained with each upgrade.
Normal use of the Servicing Director applications do not change the login access or permissions.
Therefore, contact your local IT to review changes made outside of the product to the login access rights or permissions.
The Customer Service History button uses a unique login named "Reports", a login different from the login used to log into Servicing Director.
You can use the Servicing Director LSCNFG application on the SQL server with the Run Fixrights option to reset the logins back to the automatically created proper access rights and permissions. See other articles about how to run the LSCNFG application.
If the error persists after you reset the logins using the LSCNFG application, then check to make sure the Service database state is Multi_User and not Restricted_User. See your Microsoft SQL Server support information for more information about changing the database state.
ArticleNumber:
000038545