Servicing Director Customer Self-Service Online Payment Error: "Could not find server 'Servicing_Server..."

Servicing Director Customer Self-Service Online Payment Error: "Could not find server 'Servicing_Server..."

Could not find server 'Servicing_Server' in sys.servers. Verify that the correct server name was specified. If necessary, execute the stored procedure sp_addlinkedserver to add the server to sys.servers.
A .NET Framework error occurred during execution of user-defined routine or aggregate "D_spGetCompanyWorkDays": 
System.Data.SqlClient.SqlException: Could not find server 'Servicing_Server' in sys.servers. Verify that the correct server name was specified. If necessary, execute the stored procedure sp_addlinkedserver to add the server to sys.servers.
System.Data.SqlClient.SqlException: 
   at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection)
   at System.Data.SqlClient.SqlCommand.RunExecuteNonQuerySmi(Boolean sendToPipe)
   at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(DbAsyncResult result, String methodName, Boolean sendToPipe)
   at System.Data.SqlClient.SqlCommand.ExecuteToPipe(SmiContext pipeContext)
   at Microsoft.SqlServer.Server.SqlPipe.ExecuteAndSend(SqlCommand command)
   at D_GetCompanyWorkDays.D_spGetCompanyWorkDays(SqlDateTime CutOffTime, SqlInt32 DaysInAdvance, SqlDateTime TransPostDate)

Root Cause:

Clicking Continue on the Online Payment Terms Screen (ACHWebIntro.ASPX) can cause this browser error message when the settings on the Servicing Director SQL server are incorrect.

This error can appear on other pages of Customer Self-Service, but this article is only for when clicking Continue on the Online Payment Terms Screen produces the error. If other pages have this error message, then search Knowledge Center for the other articles on the same error message.

Workaround:

This information is for your system administrator or local IT:

  1. Reset your Servicing Director SQL logins, using the LSCNFG server application, adding on executing the W_FixRights SQL command.  For more information about resetting your Servicing Director SQL logins, search Knowledge Center with the key words Resetting the Servicing Director SQL Server Logins.
  2. After resetting your logins, restart your web services (IIS) on your Customer Self-Service business application server (ILSWebBus).
  3. If the issue is not resolved at this point, then continue with the following advanced troubleshooting:
  4. From the Servicing Director SQL server, run the following troubleshooting SQL command. If an error occurs, it will be a SQL message about the root cause of this issue, and it will direct your further actions.
    1. Open the SQL Server Management Studio.
    2. Login specifically using SQL authentication and use only the SQL login ILSWebUser. This is the SQL login configured by the person installing the Customer Self-Service business application server. Use the default password defined in the Customer Self-Service Installation Guide or your custom password if the person installing Customer Self-Service defined a custom password.
    3. Click New Query.
    4. Enter the following query:

      Use Service
      Go
      Service.dbo.W_GetCompanyWorkdays
      Go

       
  5. If the settings for this query on your system are correct, then the results from the query should return the business days from the Event Manager calendar.  If the settings for this query on your system are incorrect, you will see a SQL error message, and use the error message to direct your further troubleshooting, Reference your Microsoft SQL Support resources as needed. 

ArticleNumber:

000042724