Servicing Director Customer Self-Service ReportDebug.txt Error: "...UFL 'u2lserv.dll' that implements this function is missing..."
fter GetReportLoc Before load
After load
C:\inetpub\wwwroot\ILSWebBus\rpt\<YourDocument>.rpt
After GetReportLoc
Before export CrystalDecisions.CrystalReports.Engine.FormulaException: UFL 'u2lserv.dll' that implements this function is missing.
Error in File <YourDocument> 2064_5044_{CF46E7E3-850A-4DFB-B4C3-17854012C739}.rpt:
Error in formula ArchiveKey:
'AllowArchivingServ({<YourDocument>})
'
UFL 'u2lserv.dll' that implements this function is missing. ---> System.Runtime.InteropServices.COMException: UFL 'u2lserv.dll' that implements this function is missing.
Error in File <YourDocument> 2064_5044_{CF46E7E3-850A-4DFB-B4C3-17854012C739}.rpt:
Error in formula ArchiveKey:
'AllowArchivingServ({<YourDocument>})
'
UFL 'u2lserv.dll' that implements this function is missing.
at CrystalDecisions.ReportAppServer.Controllers.ReportSourceClass.Export(ExportOptions pExportOptions, RequestContext pRequestContext)
at CrystalDecisions.ReportSource.EromReportSourceBase.ExportToStream(ExportRequestContext reqContext)
--- End of inner exception stack trace ---
at CrystalDecisions.ReportAppServer.ConvertDotNetToErom.ThrowDotNetException(Exception e)
at CrystalDecisions.ReportSource.EromReportSourceBase.ExportToStream(ExportRequestContext reqContext)
at CrystalDecisions.CrystalReports.Engine.FormatEngine.ExportToStream(ExportRequestContext reqContext)
at CrystalDecisions.CrystalReports.Engine.ReportDocument.ExportToStream(ExportOptions options)
at CrystalDecisions.CrystalReports.Engine.ReportDocument.ExportToStream(ExportFormatType formatType)
at ILSBusiness.LoanDataProvider.CrystalRptExport(ReportDocument rptDoc, StringBuilder& sb, String& debug, String currDir)
Root Cause:
This error indicates the file U2LServ.dll is missing or cannot be read.
Workaround:
The file U2LServ.dll is installed by the Customer Self-Service business application server installation to the Windows system folder, by default C:\Windows\SysWow64 on a Windows 64bit system.
Confirm whether the file is present in the system folder by searching for it.
If the file does not exist, reinstall the Customer Self-Service business application as follows:
- Uninstalling the Servicing Director Customer Self-Service Web Business from the Windows programs list.
- Installing it again by running the Customer Self-Service Web Business Only Setup.msi using a Run As Administrator procedure such as a Windows Command Prompt opened with a right-click Run as Administrator.
- Configure the Customer Self-Service business application (ILSWebBus) web.config as described in the Customer Self-Service Installation or Upgrade guide.
- Confirm whether the file is present in the system folder by searching for it.
- If the file does not exist, submit a case through Case Management to contact customer support.
If the file does exist, it may not be accessible by your Windows configuration for the IIS application pool identity Windows user you have configured to run the Customer Self-Service business application. On the web application server, confirm the IIS user has Read permission of the Windows system folder. The IIS user is the Windows account you have set for the IIS web server ILSWebBus1 application pool identity. By default, the IIS user will be the ApplicationPoolIdentity or Network Service user. These users will be in the IIS_IUSRS group on Windows versions later than Windows 2008, and the installation will automatically assign these permissions using the IIS_IUSRS group. Your IIS user configuration may be different than the default. For more information about the Microsoft procedures for assigning folder permissions, refer to your Microsoft support resources.
ArticleNumber:
000043585