Servicing Director Link (SD Link) Connectivity Test Error: "...Login failed for user 'ILSWebUser'..."

Servicing Director Link (SD Link) Connectivity Test Error: "...Login failed for user 'ILSWebUser'..."

[CDATA[]]&gt;&lt;/Results&gt;&lt;ConnectErrors&gt;&lt;Errors Version="15.1.0.1"&gt;&lt;Map_Name&gt;ILS_LoanDetails_Export&lt;/Map_Name&gt;&lt;General_Error Error="BOServer : Login failed for user 'ILSWebUser'.&amp;#xA;" /&gt;&lt;General_Error Error="Status : Failed to get a database for data source Servicing" /&gt;&lt;/Errors&gt;&lt;/ConnectErrors&gt;</Information></ConnectServiceResponse></COMResponse>

Root Cause:

The most common cause for this message is the SD Link has the wrong password for the SQL server login named "ILSWebUser". 
Other possible issues are the login is locked, or missing in SQL server.

Workaround:

Have your database administrator check the following:

  1. Confirm there is an ILSWebUser login, and it has access to Service database.
  2. If there is no ILSWebUser login, or it does not have access to the Service database, go to the W_FixRights section described below.
  3. If there is an ILSWebUser login, and it does have access to the Service database, then confirm the ILSWebUser login is unlocked.
  4. Confirm the password for the ILSWebUser login.  The default password is defined in the SD Link Installation Guide section titled "Connecting to the Database Server". You may or may not be using the default password.
  5. Once you confirm the password set on the SQL server, set the same password using the Servicing Director Link Connection Editor as described in the Installation Guide.

If the ILSWebUser login does not exist on your SQL server, or it does not have access to your, execute the W_FixRights command below:

Note:  Familiarity with SQL Server is strongly recommended to complete this workaround.
  1. Open SQL Server Management Studio.
  2. Connect to the server housing your Service database.
  3. Click New Query.
  4. Select the Service database as the database for the New Query screen.
  5. Enter the following Query:
  6. EXEC W_FixRights
  7. Press the F5 key to execute the command. This will make corrects to your Service database.
  8. Exit SQL Server Management Studio.

ArticleNumber:

000043315