Installation or upgrade error: The installation cannot validate your SQL server

Installation or upgrade error: The installation cannot validate your SQL server

The installation cannot validate your SQL server connection to 'xxxxx'. Please verify that the Servicing Director database installation has been run; the correct SQL server name 'xxxxx' was entered; database login credentials have not been changed or deleted - the current credentials must be used. Verify that TCP/IP is enabled.

Note: In the example above, the 'xxxxx' is a placeholder, and your message will have the SQL server name you entered instead of 'xxxxx'.

Root Cause:
The error means the installation program failed to successfully test a connection to the SQL server using special product provided SQL login credentials.

This can be caused by the conditions described in the error message, such as when the SQL server you have has a SQL instance name in the form of server name\instance name, and entering only the server name without the \instance name leads to the error. 


Workaround:

  1. Make sure the Servicing Director SQL server name is correct:
Be sure to enter the server name without any leading \\ characters, since this is a Microsoft SQL server name and not a UNC path which uses the \\ characters. If the server name is incorrect, then the resolution is to enter the correct server name.
  1. Make sure your Servicing Director SQL server has all the required SQL logins:
One of the conditions described in the error message is an issue with the database credentials. To make sure the database credentials are correct, run the Servicing Director LSCnfg utility on the SQL server as follows:
  1. Click Start > Programs > D+H > Servicing Director Tools > LSCnfg. The LSCnfg screen will open.
  2. Confirm the Name field in the Service SQL Server section is the correct name for your Servicing Director SQL server or SQL server instance name.
  3. Enter 'sa' (without the quotes) in Sys Admin Login field.  The 'sa' login is a standard SQL login with administrator permission on the Servicing Director SQL server.
  4. Enter your 'sa' login password in the Sys Admin Password field.  The 'sa' login password would have been created by your system administrator when SQL was first installed. If you do not know what the 'sa' login password is, check with your system administrator.
  5. Confirm the Event Manager SQL Server information is correct (usually the same as the SQL server information).
  6. Confirm the Databases section has the correct names for your databases (usually the names Service and SvcEventMgr).
  7. Click the Run Fixrights checkbox to enter a checkmark.  No other fields need to be changed.
  8. Click the Apply button.
If the issue is not resolved, then the issue may be more advanced, such as a network connection issue. To test the network connections from the local computer to the Servicing Director SQL server, use Microsoft provided tools, such as the ODBC Connection test. For more information, review Testing the Network Connection to your Servicing Director Server Using the ODBC Data Source Test.

ArticleNumber:

000044197