Current Directory is C:\inetpub\wwwroot\ILSWebBus\bin
Testing application connectivity using configuration file: C:\Inetpub\wwwroot\ILSWeb\client.config
Remoting channel http is registered
PASS: A configured type ILSBusInterfaces.IDbExceptionPublisher found at http://localhost/ILSWebBus/DbExceptionPublisher.rem
PASS: A configured type ILSBusInterfaces.ILoanDataProvider found at http://localhost/ILSWebBus/LoanDataProvider.rem
PASS: A configured type ILSBusInterfaces.IUserDataProvider found at http://localhost/ILSWebBus/UserDataProvider.rem
Reference to ILoanDataProvider acquired
Logging as Doman\User
EXCEPTION ENCOUNTERED!
MESSAGE: The input stream is not a valid binary format. The starting contents (in bytes) are: 3C-21-44-4F-43-54-59-50-45-20-48-54-4D-4C-20-50-55 ...
SOURCE: mscorlib
TARGET: Void HandleReturnMessage(System.Runtime.Remoting.Messaging.IMessage, System.Runtime.Remoting.Messaging.IMessage)
STACK:
Server stack trace:
at System.Runtime.Serialization.Formatters.Binary.SerializationHeaderRecord.Read(__BinaryParser input)
at System.Runtime.Serialization.Formatters.Binary.__BinaryParser.ReadSerializationHeaderRecord()
at System.Runtime.Serialization.Formatters.Binary.__BinaryParser.Run()
at System.Runtime.Serialization.Formatters.Binary.ObjectReader.Deserialize(HeaderHandler handler, __BinaryParser serParser, Boolean fCheck, Boolean isCrossAppDomain, IMethodCallMessage methodCallMessage)
at System.Runtime.Serialization.Formatters.Binary.BinaryFormatter.Deserialize(Stream serializationStream, HeaderHandler handler, Boolean fCheck, Boolean isCrossAppDomain, IMethodCallMessage methodCallMessage)
at System.Runtime.Remoting.Channels.CoreChannel.DeserializeBinaryResponseMessage(Stream inputStream, IMethodCallMessage reqMsg, Boolean bStrictBinding)
at System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage(IMessage msg)
Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at ILSBusInterfaces.ILoanDataProvider.getCompName()
at HFSBusTest.Form1.TestRemotely(String PathFilename, String strUser, String strPassword, String strDomain)
Root Cause:
This Customer Self-Service Test Utility exception message indicates an error communicating with your Customer Self-Service business application server.
The Customer Self-Service borrower web server or investor web server communicates with the business application server that you defined in the web server Client.Config file. You defined the business application server when the installation or upgrade guide led you to edit the Client.Config file.
The exact root cause of the error communicating is not shown by this error detail, but generally speaking, the business application server has responded to the web server with a Microsoft IIS (Internet Information Server) or HTTP level error, returning an error message instead of readable data.
Workaround:
Have your system administrator or local IT review the following:
- Confirm the hostname you entered when editing the web server Client.Config is correct, and it is the server where the Customer Self-Service business application server product (ILSWebBus) is installed.
- Locate the attempt by your web server to communicate to the business application server in the Microsoft-provided IIS logs on the business application server. The log record for the communication should show a Status value, which would be the HTTP code for the error in the communication. Microsoft support resources can cross reference their HTTP code you found in the log to a fuller description of the code and perhaps lead you to the Microsoft recommended troubleshooting.
- Search the business application server Windows Event Viewer Application logs for ASP.NET errors also related to the failures to communicate, which can also lead your next troubleshooting steps.
- If you just upgraded the business application server, reinstall the business application server, as follows:
- Uninstall the "Servicing Director Customer Self-Service Web Business" product using the Windows Programs list Control Panel.
- Delete the directory where you installed the business application server product. By default, this would be the C:\inetpub\wwwroot\ILSWebBus.
- Install the business application server product again, using the Customer Self-Service Installation Guide.
- If you would like to troubleshoot and review your findings, submit a case through Case Management and attach your findings to the case.
ArticleNumber:
000043975