Servicing Director Customer Service Application Error: "Unable to open/requery MainRS..."

Servicing Director Customer Service Application Error: "Unable to open/requery MainRS..."

Unable to open/requery MainRS - using this loan id as ! From CChoosDlg::GetMainRS()


Root Cause:

This error message indicates that the selected loan you are trying to view in the Customer Service application has either missing or inconsistent data in one of the SQL tables used by the Customer Service screen.

The problem is usually caused by a custom loan import process.


Workaround:

This data problem would not clearly be evident or found in the application, so you will need your IT department or Database Administrator to assist you in troubleshooting and correcting your data.

You should have the loan data checked to make sure your custom loan import is including all the required fields and consistent data.

Servicing Director support is able to provide some troubleshooting tips which your IT department or Database Administrator can use to find and correct the issue.  However, Servicing Director support has information about the Servicing Director applications as they are installed from the product installation files, and there may not be enough information about your custom import process to fully resolve the issue. 

The authority for your custom import will be the engineering source of the import process.  If you purchased the import process from the Servicing Director Customization Professional Services department, then create a Finastra Customer Success Community Case Management case for the issue and request it be sent to the Customization department for support.

If the custom import was designed by your own resources, you can still propose purchasing engineering time from our Customization department to help you fix the problem. To request this help, create a Finastra Customer Success Community Case Management case for the issue and request it be sent to the Customization department for support.

 

Advanced Information for your your IT department or Database Administrator:

Here is the 'FROM' portion of the SQL Select statement used in the Customer Service screen.
Make sure that the loan has a record in each of the 'inner join' tables or views, and also that the data is consistent in the 'right join' tables.
Missing a record in any of these tables would result in the error message.

Once the table(s) contain the appropriate record(s), the error message should no longer appear.

 

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FROM
((((Property

INNER JOIN MailingAddress
ON Property.LoanID = MailingAddress.LoanID AND MailingAddress.PrimaryMailing = 1)

INNER JOIN Q_Loan_Plus_Reserve L
ON Property.LoanID = L.LoanID AND MailingAddress.AssmRecCounter = L.AssmRecCounter)

INNER JOIN State
ON Property.State = State.Code

INNER JOIN Delinquent
ON L.LoanID = Delinquent.LoanID)

INNER JOIN Status
ON L.LoanID = Status.LoanID)
 
INNER JOIN Borrower
ON (L.AssmRecCounter = Borrower.AssmRecCounter) AND (L.LoanID = Borrower.LoanID) AND Borrower.Position = 0

INNER JOIN Country
ON MailingAddress.CountryCode = Country.CountryCode

RIGHT JOIN Collector ON ( delinquent.collector = collector.code )

LEFT JOIN Collateral ON Collateral.LoanID = L.LoanID AND CollateralNumber <> 0

INNER JOIN Company
ON L.CompanyKey = Company.CompanyKey

LEFT JOIN SRLoanData ON SRLoanData.LoanID = L.LoanID

INNER JOIN Participation P
ON L.LoanID = P.LoanID AND P.PrimaryInvestorFlag = 1

INNER JOIN Investor
ON P.InvestorID = Investor.InvestorID AND P.PendingFlag = 0

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ArticleNumber:

000038650